La Riparazione del Flipper » Flipper » Flipper Zaccaria


 
Discussione: Zaccaria Time Machine non parte

 
Benvenuto, Ospite
Impostazioni Ospite
Discussione Archiviata Questa discussione è stata archiviata - le risposte non sono consentite.


Questo problema non è risolto. Validi aiuti disponibili: 3. Soluzioni al problema disponibili: 1.


Permlink Risposte: 8 - Pagine: 1 - Ultimo Messaggio: 9-giu-2023 12.18 di maxbesoz Discussioni: [ Precedente | Successivo ]
james100

Messaggi: 4
Registrato: 23-05-23
Zaccaria Time Machine non parte
Postato: 23-mag-2023 21.57
 
Buonasera, sono nuovo del forum e sono qui a chiedervi supporto tecnico per il mio Time Machine fermo da 30 anni....passo al problema.. prima di accendere il flipper ho scollegato tutte le schede lasciando in tensione il solo alimentatore, che dopo verifica delle tensioni sembra funzionare perfettamente...per scrupolo ho cmq sostituito i ponti radrizzatori e il condensatore del circuito di protezione quello da 1 micro F.
Ho rimosso la batteria e riparato le sottostanti piste rovinate dall'acido...pulito gli zoccoli degli integrati..... Succede che, accendendo il flipper, vedo un lampeggio seguito dalla luce fissa del led nella scheda Cpu...anche il led della scheda audio subito dopo si spegne e contemporaneamente si accendono i display 000000000 , ma poi niente, tutto fermo... non entra in programmazione con lo sw4 e non sente i comandi credito/partita....ogni tanto alla prima accensione si eccita la bobina del clok , oppure il motore dell'ascensore.
Ecco, spero di aver descritto bene il problema e spero che qualcuno possa aiutarmi... ho una discreta manualità con l'elettronica base (transistor,diodi,resistenze,condensatori,porte logiche )... ma di programmazione zero.....vorrei mantenere l'originalità del flipper, anche se in alternativa ho visto che esistono in commercio schede universali per questi Zaccaria di 2° generazione....cosa mi consigliate?
Grazie
tyutyu007

Messaggi: 472
Registrato: 09-08-08
Re: Zaccaria Time Machine non parte
Postato: 24-mag-2023 5.58   in risposta a: james100 in risposta a: james100
 
Ciao !

Se hai buone capacità di saldatura, puoi anche acquistare una scheda vuota.
Puoi fare una buona carta a buon mercato usando le tue vecchie parti.
Oppure acquista una scheda semilavorata (senza eprom e processore) se la tua è buona - di nuovo otterrai una nuova scheda più economica.
Se non vuoi o non puoi saldare, puoi anche acquistare schede plug&play complete. Molti di noi li vendono.

Se vuoi rimanere con l'originale, puoi anche acquistare una vecchia carta originale ( privo di acidi ! ).

Puoi scegliere tra diverse opzioni.

Modificato da: tyutyu007 il 24-mag-2023 5.02

Modificato da: tyutyu007 il 24-mag-2023 5.04
maxbesoz


Messaggi: 1.215
Registrato: 31-08-07
Re: Zaccaria Time Machine non parte
Postato: 24-mag-2023 13.26   in risposta a: james100 in risposta a: james100
 
ciao,

il tuo Time machine è uno zaccaria di seconda generazione, più affidabile rispetto alla prima generazione

Il led rosso sulla scheda cpu è gestito da un latch connesso al data bus e segnala (o dovrebbe segnalare) il corretto funzionamento del software

Più precisamente il led è gestito dal latch IC11 pin 14 (DB5), IC11 pin 1 (uscita del latch) e driver IC12 (CA3081 o equivalenti). DB5 indica il databus bit 5 connesso alle memorie ed al micro 2650

Anche i segnali RUN e RUNEN sono gestiti da IC11, mentre il watch-dog è gestito da IC33. Il segnale RUN abilita, quando è basso le schede connesse alla cpu (Interface, Audio e Display)

Il watch-dog è il segnale RFSH collegato ad IC33 pin 1. e, quando è ad 1 logico, resetta il contatore IC14 (74LS393). Se il contatore non viene resettato entro alcuni ms, la sua uscita si porta ad 1 attivando il transistor NPN TR1 che a sua volta, tramite IC13, pin 11,10, resetta il micro e toglie momentaneamente il RUN. E' evidente che se il latch parte ad 1 logico ed il software non gira, questo manterrà sempre resettato il contatore, mancando quindi la sua funzione di sicurezza

Questa gestione delle abilitazioni e del watch-dog è totalmente errata (ed è l'unico appunto da fare alla scheda) per i seguenti motivi:
1- non si deve MAI affidare ad un circuito con memoria (latch) la gestione della sicurezza, perché, se all'accensione il latch si configura in modo errato, quindi abilitando le periferiche (RUNEN=0 -> RUN=0) anche se il software fosse bloccato, le periferiche sarebbero abilitate, con eventuali bruciature di bobine o altri guai. Infatti non essendoci comandi dal micro, il latch rimarrebbe in ok abilitando tutto senza che la cpu funzioni
2- idem per il led. Se il software fosse bloccato ed il latch partisse con un 1 sul pin 1, il led rimarrebbe acceso ad indicare tutto ok, mentre invece sarebbe tutto bloccato.

Anche gli 0 che appaiono sui display sono dovuti al fatto che c'è RUN=0 (OK) e la parte di dma funziona, garantendo il refresh dei digit, anche con il software bloccato

La gestione del watch-dog e delle segnalazioni di OK vanno sempre affidate a circuiti senza memoria, ad esempio monostabili retriggerabili e circuiti a finestra temporale

Detto ciò, dovresti controllare con un oscilloscopio alcuni segnali

Però prima dovresti dire se lo possiedi e se lo sai utilizzare

Dovresti anche mettere delle foto della scheda cpu sia lato componenti che lato saldature, soprattutto evidenziando le zone dove l'acido aveva intaccato le piste del pcb

Questi sono i danni peggiori, perché bisogna battere tutti i collegamenti con il tester in modalità cicalino e verificare la continuità delle piste

Inoltre, per quanto tu possa pulire la scheda, le molecole di acido che si sono insinuate tra la vetronite ed il rame continuano a lavorare per cui, magari a distanza di mesi, ti ritroverai con altri malfunzionamenti

Comunque, se il danno è circoscritto puoi tentare la riparazione

ciao

massimo
james100

Messaggi: 4
Registrato: 23-05-23
Re: Zaccaria Time Machine non parte
Postato: 24-mag-2023 21.05   in risposta a: tyutyu007 in risposta a: tyutyu007
 
La ringrazio per avermi informato di queste proposte alternative...purtroppo non conosco ancora il componente guasto e rischierei di riportarlo sulla nuova scheda, comprese le Eprom...sono più orientato sulla riparazione o eventualmente su una scheda plung&play chiavi in mano, ovvero senza metterci mano...nemmeno il trasferimento della cpu in quanto non sono sicuro che funzioni.
Se non le dispiace, vorrei risentirla nel caso la riparazione non vada a buon fine. La ringrazio nuovamente
james100

Messaggi: 4
Registrato: 23-05-23
Re: Zaccaria Time Machine non parte
Postato: 24-mag-2023 22.21   in risposta a: maxbesoz in risposta a: maxbesoz
 
Buonasera Max... mi scuso per essermi fatto attendere, ma trovo il tempo per scrivere solo la sera....La ringrazio per la sua spiegazione approfondita e competente... l'oscilloscopio lo sò usare ma è guasto pure quello...volevo aggiungere però, che il flipper molto probabilmente è stato depositato in cantina 30 anni fà già in condizione di guasto...ovvero c'è già stato un tentativo di riparazione( mio papà era tecnico)...., in quanto ho trovato un ponte radrizzatore scollegato , e l'acido della batteria non ha fatto grossi danni... come da foto la corrosione ha interessato solo 3 saldature sotto la batteria , che ho provveduto a ripristinare le piste con dei ponticelli ..
Ho anche scollegato (tagliato) momentaneamente il filo del power failure.. ma non è successo nulla.
Le chiedo...supponiamo che il guasto si sia verificato già all'epoca senza gli aggiunti problemi dell'acido e con il circuito stampato in ottime condizioni, ovvero a flipper nuovo.....saprebbe Lei indicarmi quali componenti potrebbero essere la causa ed eventualmente da sostituire...cosi per tentativi....Ovviamente sono consapevole che la mia richiesta è da cestino ...però un tentativo io lo farei volentieri....ho buona manualità e i componenti li dissaldo con l'aria compressa senza intaccare minimamente le piazzole...cioè, non farei ulteriori danni.
In attesa di risentirla, la ringrazio nuovamente
maxbesoz


Messaggi: 1.215
Registrato: 31-08-07
Re: Zaccaria Time Machine non parte
Postato: 25-mag-2023 9.42   in risposta a: james100 in risposta a: james100
 
ciao,

senza oscilloscopio sarà certamente molto più difficile

Dalla foto della scheda cpu vedo che almeno i ponticelli di configurazione delle tre eprom 2532 sono corretti

Una domanda: il led rosso si accende subito, oppure passano circa 1 o 2 secondi prima che si accenda? Questo mi dice se qualcosa gira oppure non. E poi si accende sempre oppure alcune volte rimane spento?

Bisognerebbe anche verificare che le tre eprom siano ok, ma occorre un eprom programmer che gestisca le 2532; sono molto vecchie ed obsolete da decenni, per cui i programmatori di eprom cinesi di adesso non le gestiscono

Un guasto su una eprom potrebbe dare i difetti che dici

Il Power Failure è innocente, in quanto, se ci fosse, terrebbe spenti i display (run inattivo) oltre che tenere attivo il reset del 2650 (vedi schema)

Dalla foto vedo però che lo zoccolo del 2650 è ossidato, va sostituito, così come vanno delicatamente puliti i pin del 2650

Sarebbe comunque bene armarsi di pazienza e battere tutta la scheda per verificare, se già non lo hai fatto, che tutte le connessioni siano ok, così come i connettori

Hai già provato a sconnettere il flat cable sia della scheda audio che della Interface e verificare se cambia qualcosa accendendo il flipper?

Può accadere che un guasto su queste schede blocchi la cpu

Allo stato attuale non mi sento di indicarti quale componente sostituire. Prima fai le verifiche che ti ho detto

Possono esserci svariati componenti che bloccano la scheda, a cominciare dalle eprom, dalla ram, dal 2650, dal decoder sia delle memorie (IC17 e circuiteria annessa) che degli I/O (IC32 e circuiteria annessa), cioè praticamente il 90% dei componenti sulla scheda cpu

L'ideale sarebbe se riuscissi a farti prestare un oscilloscopio , oppure potresti acquistarne uno su bangood o similari, tipo MDS8207 (86,57? iva compresa su bangood). Io lo posseggo e lo uso per piccoli test al volo. Chiaramente non è lontanamente paragonabile all'oscilloscopio principale che utilizzo (un 4 tracce da 300MHz Rigol), ma va più che bene per i tuoi usi

Il link è https://it.banggood.com/Upgraded-MUSTOOL-MDS8207-Intelligent-2-in-1-Digital-40MHz-200Msps-or-S-Oscilloscope-6000-Counts-True-RMS-Multimeter-p-1496130.html?cur_warehouse=CN&rmmds=search

ciao

massimo
james100

Messaggi: 4
Registrato: 23-05-23
Re: Zaccaria Time Machine non parte
Postato: 8-giu-2023 21.26   in risposta a: maxbesoz in risposta a: maxbesoz
 
Buonasera Sig. Massimo
Purtroppo io non ho le sue competenze ed ho preferito arrendermi con la riparazione... ho però trovato on line una nuova scheda "Time Machine" a buon prezzo ed adesso il flipper funziona perfettamente.
Ho cmq bisogno ancora de suo aiuto....succede che, provando e riprovando, accendendo e spegnendo.. un digit del display centrale (come da Foto) non si accende più... questa è senz'altro una riparazione alla mia portata e sono a chiederle ... quale componente del display potrebbe essersi guastato? il difetto lo faceva anche con la precedente scheda CPU, e pertanto presumo si tratti proprio dello schedino display.

Come da foto, ci sono anche altri display con segmenti parzialmente funzionanti o lampeggianti...forse esauriti?
Ecco, la ringrazio nuovamente per questa nuova cortesia.

Bruno
tyutyu007

Messaggi: 472
Registrato: 09-08-08
Re: Zaccaria Time Machine non parte
Postato: 9-giu-2023 6.53   in risposta a: james100 in risposta a: james100
 
Questo vetro del display non è più disponibile.
Se sei fortunato, è solo un guasto elettronico (4028, transistor BF) o solo un giunto di saldatura rotto.
Il caso peggiore è il vetro stesso, ma ci sono diverse soluzioni anche per questo.
maxbesoz


Messaggi: 1.215
Registrato: 31-08-07
Re: Zaccaria Time Machine non parte
Postato: 9-giu-2023 12.18   in risposta a: james100 in risposta a: james100
 
ciao,

i digit parzialmente funzionanti o lampeggianti indicano problemi ai vetri (cioè il vero e proprio visualizzatore)

Questi display sono a scarica di gas ed un malfunzionamento tipicamente si traduce in assorbimenti anomali sui 170V e conseguente rischio per l'alimentatore

Meglio sostituirli

Non conviene più perdere tempo anche per il display con il digit centrale spento (potrebbe essere un transistor tra TR15 e TR21, bisogna risalire alla piedinatura del vetro per capirlo)

Curiosità: la schede cpu presa su internet è originale?

ciao

massimo


VecchiFlipper forum © 2010