La Riparazione del Flipper » Flipper » Flipper Elettronici


 
Discussione: Flipper Williams HYPERBALL (1980) problema matrice lampade

 
Benvenuto, Ospite
Impostazioni Ospite
Questo problema è risolto. Validi aiuti disponibili: 2. Soluzioni al problema disponibili: 1.


Permlink Risposte: 9 - Pagine: 1 - Ultimo Messaggio: 13-ott-2017 20.18 di alessandro Discussioni: [ Precedente | Successiva ]
theloris


Messaggi: 713
Registrato: 08-12-11
Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 27-lug-2017 23.27
 
Ciao a tutti, da poco ho portato a casa questo "flipper particolare", anche se flipper non si pu chiamare visto che, per chi non lo dovesse conoscere, un incrocio fra videogioco e i cannoncini dei baracconi.
Comunque, tornando al titolo del post, ho un problema sulla matrice lampade. Rispetto ad un semplice flipper questo ha ben due matrici distinte, e sulla seconda matrice (8 colonne x 4 righe) la riga 11 completamente fuori uso. Schemi alla mano, che qui allego, si vede che il segnale esce dal PIA 6821 dal pin 5 e va al 7406. Da qui il segnale viene negato per passare poi attraverso diodi/resistenze/transistor.
Tramite sonda logica ho analizzato il segnale in uscita dal pin 10 di ic1 ed pulsante high-low, mentre tutte le altre uscite sono pulsanti ma solo low.. quindi ho pensato fosse questo e l'ho cambiato ma senza successo.
Avete qualche consiglio su come affrontare il problema?
Grazie
Loris
--
Saluti

La mia "collezione": http://www.collezionistidiflipper.it/theloris
maxbesoz


Messaggi: 573
Registrato: 31-08-07
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 28-lug-2017 10.48   in risposta a: theloris in risposta a: theloris
 
ciao,

cosa intendi pulsanti solo LOW? se pulsano vuol dire che si alternano low ed high. I 7406 sono open collector, hai controllato la resistenza di pull-up da 1K2? Un altro problema pu essere l'scr di protezione S2 in corto, per cui ti mantiene bassa la base del darlington Q17. Anche D4 aperto o la resistenza di potenza R11 aperta o fuori specifica darebbero lo stesso problema. R4 comporterebbe un intervento anomalo di S2

saluti

massimo
theloris


Messaggi: 713
Registrato: 08-12-11
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 28-lug-2017 11.55   in risposta a: maxbesoz in risposta a: maxbesoz
 
maxbesoz ha scritto:
cosa intendi pulsanti solo LOW? se pulsano vuol dire che si alternano low ed high
Sulla sonda logica ci sono i tre led rosso (High) - giallo (pulse) - verde (low).
Gli altri segnali in uscita sono solo giallo-verdi, dal pin 10 invece ho tutti e tre i led accesi (per quello che dicevo pulsante high-low).
A parte diodi e resistenze, c' modo di verificare gli altri componenti, prima di cambiarli tutti a "caso"?
Grazie
Ciao
--
Saluti

La mia "collezione": http://www.collezionistidiflipper.it/theloris
maxbesoz


Messaggi: 573
Registrato: 31-08-07
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 28-lug-2017 12.01   in risposta a: theloris in risposta a: theloris
Valido aiuto
ciao,

prova a vedere se S2 in corto. Puoi sollevare il pin che connesso all'uscita di U1/10. Se tutto torna in funzione, S2 in corto. Il principale imputato potrebbe pero essere Q17. Se cortocircuiti collettore-emettitore la riga si accende? fai un corto breve per non sovraccaricare le lampadine. Controlla anche D4. Potresti poi sconnettere il pin 10 di U1 e vedere se la matrice si accende

saluti
theloris


Messaggi: 713
Registrato: 08-12-11
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 28-lug-2017 13.50   in risposta a: maxbesoz in risposta a: maxbesoz
 
Ti ringrazio per la bella spiegazione! Direi che non mi resta che fare le prove che mi hai detto... poi ti aggiorno sui risultati! ;)
Su Q17 si potrebbe per aprire un dibattito. A schema originale viene indicato come "NPN darlington transistor" ma senza tipo, solo con il seriale Williams che 5162-09410-00 che, tramite Google, corrisponde ad un semplice TIP102.
Su di un altro schema non ufficiale che si trova su ipdb, e del quale ho allegato appunto la foto, Q17 un 2N6427 che ben diverso. Per caso sapresti spiegarmi questa evidente differenza?
Ti ringrazio per il momento!!! :)
--
Saluti

La mia "collezione": http://www.collezionistidiflipper.it/theloris
maxbesoz


Messaggi: 573
Registrato: 31-08-07
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 28-lug-2017 19.30   in risposta a: theloris in risposta a: theloris
 
ciao,

non saprei, il 2N6427 un darlington da 500mA, quindi ovviamente non adatto a pilotare alcunch di potenza. Comunque sulla scheda vedi se un contenitore TO92 (2N6427) od un TO220 (TIP102)

saluti

massimo
theloris


Messaggi: 713
Registrato: 08-12-11
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 28-lug-2017 19.43   in risposta a: maxbesoz in risposta a: maxbesoz
 
Non male... infatti.. malissimo! Cambiato diodi con 1N4007, cambiato il tip con un bdx53c (solo perch avevo gi la scheda sul banco), ricollego il tutto e... nn solo la riga 11 ancora out, ma la colonna 1 della seconda matrice out, e la seconda colonna invece sempre accesa.. ma che diavolo sta succedendo?!?!?!
Devo tornare indietro per vedere cos'ha contribuito a tutto ci... un passo alla volta...
--
Saluti

La mia "collezione": http://www.collezionistidiflipper.it/theloris
theloris


Messaggi: 713
Registrato: 08-12-11
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 5-ago-2017 12.54   in risposta a: theloris in risposta a: theloris
 
Piccolo aggiornamento pre-vacanze.
Testata la scheda a banco con sonda logica, risultato che l'uscita al pin 5 del pia 6821 (che gestisce la riga 11) non era pulsante come le altre. Inoltre 3 uscite (pin 15-16-17) erano in corto a causa di ic 8.
Cambiati entrambi, sia pia che ic 8, tutte le lampade ora funzionano finalmente.
Il problema per si spostato tutto sui solenoidi. Flashers e motore recupera palline sono out!
Ora qualche giorno di meritato relax e poi si ritorna a sudare :)
Buone vacanze a tutti!!!
--
Saluti

La mia "collezione": http://www.collezionistidiflipper.it/theloris
theloris


Messaggi: 713
Registrato: 08-12-11
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 12-ott-2017 15.02   in risposta a: theloris in risposta a: theloris
 
Allegato HB.jpeg (226,7 KB)
A titolo informativo, problema risolto! La linea solenoidi era out, sicuramente un corto o qualcosa del genere ha fritto ben 7 TIP120 su 8, e in pi il segnale di blanking (gestito da IC3 e IC7) era costantemente basso. Sostituendoli entrambi (7400 - 7408) il tutto ritornato a funzionare correttamente, motore palline compreso cambiando il transistor dedicato Q54 (2N4403).
Ora manca da cambiare un opto in corto per il bersaglio "M" e caricare le oltre 50 palline :)
Ciaooo
--
Saluti

La mia "collezione": http://www.collezionistidiflipper.it/theloris
alessandro


Messaggi: 743
Registrato: 11-07-12
Re: Flipper Williams HYPERBALL (1980) problema matrice lampade
Postato: 13-ott-2017 20.18   in risposta a: theloris in risposta a: theloris
 
theloris ha scritto:
A titolo informativo, problema risolto! La linea solenoidi era out, sicuramente un corto o qualcosa del genere ha fritto ben 7 TIP120 su 8, e in pi il segnale di blanking (gestito da IC3 e IC7) era costantemente basso. Sostituendoli entrambi (7400 - 7408) il tutto ritornato a funzionare correttamente, motore palline compreso cambiando il transistor dedicato Q54 (2N4403).
Ora manca da cambiare un opto in corto per il bersaglio "M" e caricare le oltre 50 palline :)
Ciaooo

complimenti loris anche se non e' un flipper sicuramente c'e' da divertirsi grande continua cosi'


VecchiFlipper forum © 2010