La Riparazione del Flipper » Flipper » Flipper Zaccaria


 
Discussione: Restauro Star God e problemi CPU

 
Benvenuto, Ospite
Impostazioni Ospite
Questo problema è risolto.


Permlink Risposte: 45 - Pagine: 1 - Ultimo Messaggio: 19-giu-2020 22.35 di edo421 Discussioni: [ Precedente | Successiva ]
edo421

Messaggi: 48
Registrato: 27-05-20
Restauro Star God e problemi CPU
Postato: 27-mag-2020 15.22
 
Salve a tutti, sono nuovo anche se da un po' leggo quello che scrivete su questo forum.

Ho recentemente acquistato uno Star God non funzionante.

Ho verificato alimentatore ed era tutto ok (voltaggi compresi) a parte un paio di porta fusibili da sostituire.

C'era un po' di corrosione data dalla pila che ho rimosso e sostituito temporaneamente con due AA (disattivando la resistenza di ricarica ;-).
Ho provveduto a pulire per bene i residui e a verificare la continuità di tutti i segnali delle rom.

Ora si accende, riesco a programmare la ram e entra in partita perfettamente. Anche i test sono tutti ok.

Se non fosse che a random si blocca o si comporta in modo strano.

Mi sono messo a smanettare e ho raggiunto la seguente situazione per escludere più cose possibili durante le mille misurazioni che ho fatto con l'oscilloscopio
Con tutto staccato (compresi CN8 e CN9) se non il display dei crediti, se, utilizzando un diodo, vado in test mode 03 succedono due cose: o mi da dei valori sbagliati, (ad esempio in corrispondenza dello 03 della matrice mi da 08, 04 diventa 26, 05 -> 52) oppure mi vengono fuori dei numeri della col 7 o col 0 senza che io tocchi nulla.
Tra l'altro quando fa così, la parte sx del display dei crediti si spegne a volte al posto che rimanere il codice dell'ultimo contatto chiuso per poi riaccendersi quando chiudo di nuovo il contatto.

Ho concluso che non si può trattare dell'IC40-41 perché con CN8-9 scollegati sono ininfluenti. Pensavo più a un problema di RAM o di IC25 (le resistenze pull-up sono a posto), voi cosa dite?

Questo succede di solito dopo che lo uso da almeno 4-5 minuti e da lì in poi diventa inutilizzabile per ovvi motivi. Anche spegnendo e riaccendendo va per mezzo minuto e poi torna in questo strano stato.

Per il resto tranne qualche lampadina bruciata e un flicker delle 5000-20000 punti (su cui non ho ancora approfondito) funziona tutto quando riesco ad usarlo.

Vi ringrazio tutti già in anticipo per tutte le preziosissime informazioni che si trovano in questo forum.
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 27-mag-2020 17.30   in risposta a: edo421 in risposta a: edo421
 
Sfortunatamente, questi sintomi tendono ad essere solo una delle acidificazioni.
Durante il funzionamento, quando il PCB si riscalda, inizia a causare guasti di contatto.
Tutto sul banco prova può essere buono, ma avvitato stringe il pannello e provoca nuovamente un errore di contatto.
Ho incontrato molti di questi prima ...
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 27-mag-2020 17.35   in risposta a: edo421 in risposta a: edo421
 
Quindi dici che è meglio che rinfresco tutte le saldature e ricontrollo ancora meglio tutti gli zoccoli?
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 27-mag-2020 18.47   in risposta a: edo421 in risposta a: edo421
 
Devi sapere se ne vale la pena.
Alla fine, il pannello di solito è sempre attorcigliato, deformato.
Il film tende anche a bruciare o strappare.
So per esperienza che riparare i pannelli acidi è buono solo per un po '.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 27-mag-2020 19.19   in risposta a: tyutyu007 in risposta a: tyutyu007
 
Mah, i realtà è messo piuttosto bene, c?era solo un pochino di blu negli zoccoli delle due ROM vicine all pila, niente di più. Potrebbe invece essere un integrato fulminato o sarebbe improbabile il funzionamento intermittente? Sto provando Intanto a rifare i giunti peggiori.
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 27-mag-2020 19.26   in risposta a: edo421 in risposta a: edo421
 
Spero vada bene.
Vai sistematicamente : processore, eprom, memorie.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 27-mag-2020 23.06   in risposta a: edo421 in risposta a: edo421
 
Ho rifatto le saldature a tutte le rom, processore e buffer collegati sul bus. Il problema sembra rimanere, domani farò altre prove. Mi sono concentrato particolarmente su tutti i pin di controllo dei chip e a DB7 che è quello che mi da problemi. Ho provato anche a metterci un pull-up da 10K come suggeriva massimo in un altro thread.
Qualche consiglio su come provare a vedere questo segnale fuori posto sull?oscilloscopio? C?è un sacco di attività sul bus e non è facile capire se c?è un problema.
Altrimenti aspetto che mi arrivi un buffer di ricambio e provo a sostituire quello.
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 28-mag-2020 8.14   in risposta a: edo421 in risposta a: edo421
 
ciao,

letture sbagliate degli switch spesso sono dovute a problemi sulle colonne (40097) che si affacciano sul bus dati

Consiglio di usare i 4503 al posto dei 40097, introvabili

Ora sono di fretta, vedrò se posso consigliare qualcosa di più preciso

ciao

massimo
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 28-mag-2020 8.47   in risposta a: maxbesoz in risposta a: maxbesoz
 
Grazie massimo, li ho ordinati, anche se non credo siano il problema. Per provare ho messo un pull-up sull'output del buffer che fa col7 e ho staccato il piedino corrispondente ma il problema rimane.

Ora mi vanno anche tutti a zero i display ogni tanto, oppure nel test 3 mi comincia a contare nella parte sinistra dei credit come se fossi in test 5, quindi non so più molto che pesci pigliare.

Posso ordinare al limite zoccoli nuovi per tutte le rom e provare a vedere se sono conciati male quelli, anche illuminando lateralmente di corrosione non mi sembra ce ne sia particolarmente.
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 28-mag-2020 15.38   in risposta a: edo421 in risposta a: edo421
 
ciao,

per scrupolo dovresti controllare il segnale IOR su U28/1 (4012). E' l'enable alla lettura 8 colonne switch

Va a 0 quando legge le colonne

Altri segnali che possono corrompere il bus dati sono quelli di vettorizzazione dell'interrupt, gestiti dal segnale INTACK negato del 2650

Esistono due vettori di interupt, il principale è quello di timer generato, l'altro quello del Test Enable premuto

Anche qui ci sono i famigerati 40097

Ovviamente do per scontato che tu abbia minuziosamente controllato e disossidato tutti i connettori

ciao

massimo
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 29-mag-2020 10.24   in risposta a: maxbesoz in risposta a: maxbesoz
 
Grazie massimo, li verificherò.

Mi sa che ho bruciato l'IC39 4528, perché non ho più impulsi sul TP 17 e sono sicuro che l'altro giorno ci fossero.
enricoto


Messaggi: 76
Registrato: 02-11-09
Re: Restauro Star God e problemi CPU
Postato: 29-mag-2020 15.50   in risposta a: edo421 in risposta a: edo421
 
Ti succedono le stesse cose che sono successe anche a me. Rifai il giro di tutti i TP. Tieni una sonda su TP18 perché forse il 2650 era fermo.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 29-mag-2020 20.09   in risposta a: enricoto in risposta a: enricoto
 
Domani mi metto e ricontrollo tutti i TP. Ma giusto per capire, su TP17 deve esserci sempre un'onda quadra oppure no?

Perché prima l'ho acceso di nuovo ed è andato perfettamente per un minuto o due, quindi mi sembra impossibile che sia bruciato qualche integrato.

Poi mi capita anche che si resetti e vada tutto a 000000 però se non spengo e riaccendo rimane bloccato lì.
Oppure ci sono i 666666 999999 ma vanno un po' giusti e un po' cambia solo l'ultima cifra.
enricoto


Messaggi: 76
Registrato: 02-11-09
Re: Restauro Star God e problemi CPU
Postato: 30-mag-2020 3.20   in risposta a: edo421 in risposta a: edo421
 
le cifre sembrano "lente" a cambiare? Succede anche a me...
Su tp17 credo ci voglia sempre un impulso negativo ogni 7-8ms. Però lo vedi solo se il 2650 seleziona la porta con il 4028.

Enrico

Modificato da: enricoto il 30-mag-2020 3.47
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 30-mag-2020 7.45   in risposta a: enricoto in risposta a: enricoto
 
Si quando fa così si, le cifre di sx lente e l'ultima a dx che saltella tra 6 e 9, ma è una cosa sempre un po' random, sono sicuro che adesso vado ad accenderlo e funziona.

Mi sembra dallo schema che IC39 non abbia input (nel senso che non dipende da nessun segnale in ingresso se non quello di reset), quindi TP17 dovrebbe essere sempre uguale e al limite TP16 essere attivato dal 2650, o mi sfugge qualcosa?

Tu come avevi risolto?

Modificato da: edo421 il 30-mag-2020 7.45
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 30-mag-2020 8.26   in risposta a: maxbesoz in risposta a: maxbesoz
 
Allegato COL0.jpeg (2.6 MB)
Allegato INTREQ.jpeg (191.0 KB)
Allora sono andato a controllare tutto di nuovo. In realtà i segnali del 4528 ci sono eccome, mi sarò confuso io.

Ci sono sia INTREQ che INTEN e RUN rimane attivo. Ci sono anche IOR e IOW che credo siano corretti. Sembra insomma che tutto stia funzionando regolarmente.
Però dopo mezzo minuto comincia a leggere sbagliate le COL, magari si riavvia e poi smette completamente di rispondere ai contatti, anche se gli impulsi prima del buffer delle COL arrivano. Schermi tutti su 000000 ma ovviamente non riesco poi più ad uscire da questa modalità.

Quindi credo aspetterò che mi arrivino 4503 per cambiare i buffer delle colonne a questo punto.

Vi faccio sapere se ci sono novità.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 6-giu-2020 21.28   in risposta a: maxbesoz in risposta a: maxbesoz
 
Dopo qualche giorno di pausa mi rimetto al lavoro sullo Star God.
Ho un display LCD quindi posso alimentare la CPU dal banco e misurare con l'oscilloscopio con meno fatica.

Ora i sintomi sono questi, 999999 666666 per qualche istante, poi 999996 999999 e dopo un po' 000000 fisso. Cosa può causarlo?

I TP mi sembrano tutti a posto. Gli impulsi sulle colonne ci sono, quando va per qualche secondo mi rileva il contatto di test correttamente.

Il tutto completamente a random, dite che è una scheda spacciata?
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 9.23   in risposta a: enricoto in risposta a: enricoto
 
Io sul TP17 in realtà ho un impulso negativo con 240ns di larghezza... Mi sa che è troppo breve!
Poi con un periodo di 15ms, che mi sembra almeno il doppio di quello che dovrebbe.
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 10.00   in risposta a: edo421 in risposta a: edo421
 
ciao,

su TP17 è corretto leggere quella durata

Appena il Q del monostabile commuta a 0, il segnale è riportato sul suo trigger negato tramite le porte U22, U23, U29 per cui ricommuta ad 1 e così via

Questo è il motivo per cui segue un flip-flop S/R realizzato con le porte U24, U37. Ha il compito di memorizzare la commutazione per allungarla e renderla disponibile al pin INTREQ del 2650

Il flip-flop è resettato dal segnale INTACK, qualche us dopo

Il periodo di INTREQ deve essere tra 7.2 e 8.8ms

ciao

max
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 14.07   in risposta a: maxbesoz in risposta a: maxbesoz
 
Allegato IMG_1453.jpeg (2.8 MB)
Guardandoci meglio l'oscilloscopio mi faceva una misurazione che non era giusta. In realtà il periodo è 7.6-7.7 quindi perfettamente nel tuo range.
Almeno questo posso essere sicuro che è a posto. Il problema è che tutti i display vanno a zero.
Da cosa può essere causato?

Edit: In realtà ora mi sono accorto che il TP 18 (RUN negato) fa un impulso alto quando va tutto a zero. Cercherò di capire come mai, credo sia il watchdog.
Edit 2: È il watchdog che si triggera a volte, non succede sempre però. A volte va a zero senza che il TP18 vada alto. Mi sta venendo il dubbio che possa essere il mio processore che è di quelli su ceramica bianca che sta tirando le cuoia. Ho allegato una foto del segnale A del mux 11/4028 in corrispondenza del segnale del watchdog. B e C sono di solito alti quando succede.

Modificato da: edo421 il 7-giu-2020 14.14

Modificato da: edo421 il 7-giu-2020 14.28
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 15.28   in risposta a: edo421 in risposta a: edo421
 
Rileggendo messaggi di max su altri thread, il fatto che a volte vada in stop il processore, in corrispondenza dell'esecuzione di una istruzione HALT 0x4 (che coincide con 10000000), mi fa pensare di nuovo al problema iniziale di lettura della COL7.
Mi viene quasi da scollegare uno ad uno i buffer che sono collegati a COL7 e vedere se cambia qualcosa. Purtroppo mi devono ancora arrivare i 4053 per sostituirli.
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 15.52   in risposta a: edo421 in risposta a: edo421
 
ciao,

se il monostabile del watch-dog ha valori di on troppo corti, succede che venga resettata la catena di temporizzazione del circuito dma.

Questo provoca rallentamenti nella visualizzazione e blocchi dell'INTREQ

Si risolve aumentando la capacità di C16 (mettere in parallelo un condensatore da 1uF, meglio se non polarizzato, tipo un multistrato, oppure sostituire C16 con un 2.2uF)

Quando i display vanno a zero, si interrompe la partita o tutto prosegue come nulla fosse?

Se si interrompe tutto significa che scatta il reset, altrimenti no

L'impulso alto su RUN negato in corrispondenza dello 0 display sembra indicare un reset

Tutto ciò che dico presuppone ovviamente che gli zoccoli del 2650 e delle eprom siano ok e che il segnale di POWER FAILURE sia inattivo

ciao

massimo
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 17.45   in risposta a: maxbesoz in risposta a: maxbesoz
 
Allegato WatchDog.jpeg (2.6 MB)
Allora sono al banco quindi ho solo la scheda CPU collegata con +12v -5v GND e +5
Power failure ho verificato che non si attiva.

Credo però che il watchdog si attivi a volte realmente perché come vedi in foto l'attività del processore si interrompe (in giallo è il pin 12 dell'U39 e in blu TP18).
Gli zoccoli li ho puliti meglio che potevo, ho testato la continuità e c'è quasi 0 ohm tra tutte le linee di tutte le eprom e il processore.

Considera però che tante volte va tutto a zero senza che avvenga alcun Reset.
Quando è spenta da un po', per il primo minuto o due funziona 666666 999999, entro nei test con l'aiuto di un diodo e va tutto bene.
Fino a quando o si spegne o va tutto a zero e da lì non riesco più a fare niente se non resetto o spengo tutto.
Dopodiché va per qualche secondo alla volta e continua a bloccarsi.

La partita si interrompeva, infatti era ingiocabile se non in quel breve frangente iniziale, per quello l'ho tirata giù.
Però non è fermo perché quando rimane 000000, fa comunque scanning delle ROW anche se non risponde ai tasti.

PS: A volte collego EXT-Reset a GND per resettare e riprovare senza spegnere gli alimentatori. Viene 666666 999999 per un secondo o anche meno e poi subito tutto a 000000
Le volte che invece funziona e va nei test, il primo sintomo è la lettura erronea di tasti sulla COL7. Comincia scrivendo (31-39-47 oppure al posto che rilevare 03 che sto collegando, rileva 08 ad esempio) poi nel giro di 10-15 secondi va in reset o tutto a zero.

Modificato da: edo421 il 7-giu-2020 17.48
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 19.50   in risposta a: edo421 in risposta a: edo421
 
ciao,

il watch-dog non resetta la cpu, solo il circuito dma
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 7-giu-2020 20.07   in risposta a: maxbesoz in risposta a: maxbesoz
 
Ah ok, però disattiva anche gli interrupt, giusto?
In ogni caso se la cpu stesse girando dovrebbe ricominciare subito a mettere numeri sui display no?
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 8-giu-2020 8.29   in risposta a: edo421 in risposta a: edo421
 
ciao,

sì. il watch dog disabilita gli interrupt, o meglio blocca INTREQ ad 1 (inattivo)

I numeri devono riapparire quando il tutto riparte

Aspetta i 4503. Hai verificato il segnale IOR? Deve andare a 0 quando legge le colonne e poi rimanere ad 1
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 8-giu-2020 8.33   in risposta a: maxbesoz in risposta a: maxbesoz
 
Ok quindi se fosse un problema solo di watchdog dovrebbero sparire i numeri brevemente e poi ripartire senza bloccare la partita.

IOR l'avevo verificato e mi sembrava funzionasse. Compariva un treno di impulsi su col0 quando premevo il pulsante del self-test.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 8-giu-2020 10.50   in risposta a: maxbesoz in risposta a: maxbesoz
 
Un'altra domanda nel frattempo: ho due display parzialmente guasti, uno lo sostituirò con quello nuovo a led che ho preso per fare i test, l'altro invece vorrei resuscitarlo.

Una scheda ha un flicker con certi numeri, in particolare il segmento orizzontale in mezzo (forse anche quello orizzontale in basso), su tutte le cifre. Immagino sia il 4511 oppure uno dei suoi transistor.

Sull'altra scheda funzionano solo le cifre di dx di ogni cristallo mentre le altre rimangono spente. Sarà il 4042 o il 4028? Pensavo a un'anomalia su A0, causerebbe solo l'accensione delle sole cifre dispari o pari. Inoltre aveva la prima cifra di dx bruciata, c'è un alone sopra. Funziona ma quel cristallo ormai è inutilizzabile. Solo che se ne metto un'altro, vedo che è molto più luminosa e quando spengo il flipper rimane leggermente accesa ancora per qualche secondo. Immagino ci sia il Q1 o il Q7 in corto a questo punto, ci sono quasi 170V su CN2-2.

I cristalli sono sicuro che funzionino, li ho provati su un'altra scheda.

Purtroppo ho uno stock quasi inesistente di componenti di questa epoca, quindi mi viene difficile fare degli esperimenti senza ordinare qualche pezzo di ogni tipo.

Volevo un suggerimento su quale ritenete sia più semplice da diagnosticare e risolvere.

Modificato da: edo421 il 8-giu-2020 11.28
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 9-giu-2020 8.54   in risposta a: maxbesoz in risposta a: maxbesoz
 
Allegato IMG_1464.jpeg (2.7 MB)
Allegato IMG_1462.jpeg (2.7 MB)
Ho ordinato la maggior parte degli integrati della scheda, tranne alcuni che non ho trovato. Credo mi arriveranno tra qualche giorno.
Nel frattempo ho usato con successo la stazione ad aria calda (che di solito uso per lavorare sui surface mount) per dissaldare gli IC senza doverli tagliare (non ho un dissaldatore, solo pompetta manuale) e devo dire che ha funzionato alla grande.

Mi sono portato avanti rimuovendo i 40097 delle colonne, la ram 8 e li ho zoccolati. Ho provato a scambiare i due 40097 tra di loro (in attesa dei 4503) e a sostituire la ram con una 5101 che ho ordinato recentemente. Nessuna variazione per il momento.

Foto del comportamento irregolare (quando non è in reset o a 000000). Si alternano quei due stati.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 10-giu-2020 17.34   in risposta a: maxbesoz in risposta a: maxbesoz
 
Mi sono arrivati i pezzi per la scheda oggi. Ho rimosso e sostituito gli zoccoli delle eeprom 4 e 5 che erano quelli più vicini alla batteria, pulendo gli ultimi residui di acido sotto.
In ogni caso, nessuna differenza.

Mi sono messo poi a zoccolare e sostituire un po' di integrati che hanno a che fare con il 2650. Per ora ho fatto IC6-7-10-11-16-21-24-25-26-27.
Purtroppo il problema rimane uguale a prima. 999999 666666 per qualche istante, poi tutto zero e a volte anche reset del watchdog.
Dal banco sono tornato al flipper e posso confermare che in questi brevi sprazzi di vita, entra nei test e vanno le bobine nel test 5.
Ovviamente poi si blocca dopo 3-4 secondi, quindi non è un problema di DMA. Mi rimangono da sostituire IC 9-13-22-29 e poi credo di aver sostituito tutto.
A quel punto se non va ancora è per forza 2650 o una delle ROM :-(
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 10-giu-2020 20.43   in risposta a: edo421 in risposta a: edo421
 
Abbiamo pensato che hai iniziato sostituendo le parti nella presa e ci sei sopra ...
Anche per il controllo di ROM. Devi iniziare con questi !
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 10-giu-2020 21.06   in risposta a: tyutyu007 in risposta a: tyutyu007
 
Scrivi pure in inglese se sei più comodo, non capisco bene quello che dici. Le eeprom come faccio a controllarle... non ho un programmatore.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 10-giu-2020 21.14   in risposta a: edo421 in risposta a: edo421
 
Allegato IMG_1472.jpeg (2.9 MB)
Allego foto della scheda.
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 10-giu-2020 22.14   in risposta a: edo421 in risposta a: edo421
Valido aiuto
Ok, thank you. The english is better for me.

The eprom is a first thing that you must be check.
If you haven't a programmer which can read/write 2708 eproms you cannot a repair.

After that you replace the socketed parts. Ex : processor and RAM.

So you must start the check and test the socketed parts before you start repair !

Rem : You can test with 2716 eprom in a first ROM socket. Set the correct jumpers for it.
The other way : you can " wire hack" into 5x2716 your board.
If your programmer know the 2716 you can write these eproms and start the repair.

I just saw your picture : The original first eprom ( OTP ROM ) cannot writable. You MUST change it to 2716 !!!
This ROM is use a different jumper settings like the 2708 or 2716 ! Set correctly !

Modificato da: tyutyu007 il 10-giu-2020 22.15

Modificato da: tyutyu007 il 10-giu-2020 22.16

Modificato da: tyutyu007 il 10-giu-2020 22.18

Modificato da: tyutyu007 il 10-giu-2020 22.18
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 10-giu-2020 22.34   in risposta a: edo421 in risposta a: edo421
Soluzione al problema
ciao,

mi sa che a questo punto urge una controllata con il mio tester zaccaria

Troppe sostituzioni ed incertezza sulle eprom. Almeno posso leggerle, sia con il tester che con il mio programmatore

altrimenti il divertimento diventa uno stress ad inseguire un problema che magari sta da altre parti.

Come ti dissi al telefono, ho poco tempo, ma penso che a questo punto sia l'unica cosa sensata da fare

ciao

massimo
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 15-giu-2020 14.44   in risposta a: maxbesoz in risposta a: maxbesoz
 
Grazie a max per l?intervento.
È risultata guasta la ROM1 OTP. Sostituita con una 2716 e scambiati jumper.
Ora sembra funzionare senza problemi!

Grazie

enricoto


Messaggi: 76
Registrato: 02-11-09
Re: Restauro Star God e problemi CPU
Postato: 15-giu-2020 16.03   in risposta a: edo421 in risposta a: edo421
 
Interessante, mi fa piacere!
Grande Max
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 15-giu-2020 17.54   in risposta a: enricoto in risposta a: enricoto
 
Come ho scritto. Quello avrebbe dovuto iniziare ...
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 15-giu-2020 18.26   in risposta a: tyutyu007 in risposta a: tyutyu007
 
Purtroppo non avendo io a disposizione programmatori per questo tipo di rom, ho provato prima il resto che potevo fare.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 17-giu-2020 12.27   in risposta a: edo421 in risposta a: edo421
 
Ora va tutto bene, unica cosa, dopo una 30-40 minuti di gioco, si resetta e riparte tutto a zero a metà partita.
Poi di soiito va bene ancora per un buon 20 minuti prima di rifarlo.

Può essere un problema di external reset o di power good? Posso tenere un oscilloscopio acceso un?ora per vedere ma volevo sapere se avevate qualche consiglio in merito.

Qualcuno ha un elenco di gommini necessari per lo star god con le relative posizioni? Ho gia sbagliato due volte a comprarli, ad esempio quelli in alto a sx credo di aver capito che sono degli 1BIS perche con i 2 non passa la pallina, ma nel manuale non li elenca.
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 17-giu-2020 12.30   in risposta a: edo421 in risposta a: edo421
 
Proprio quando ti stai scaldando bene?
Potrebbe essere un'interruzione di corrente, ma è un componente o PCB.
Hai sostituito tutte le parti?
Quindi il PCB ...
maxbesoz


Messaggi: 925
Registrato: 31-08-07
Re: Restauro Star God e problemi CPU
Postato: 17-giu-2020 13.37   in risposta a: edo421 in risposta a: edo421
 
ciao,

da freddo scalda le schede con un phon, così vedi se è un problema di temperatura

Potrebbero essere i connettori, qualche integrato o l'alimentatore a 5V6 che va in protezione termica

Se vuoi monitorare il Power Failure, mettici un flip-flop S/R con un led ed il reset a pulsante. Il flip-flop va fatto a NAND in modo che registri la transizione 1->0 del Power Failure

ciao

massimo
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 18-giu-2020 10.40   in risposta a: maxbesoz in risposta a: maxbesoz
 
Ieri poi si resettava quando entrava in test 4 luci.
Ho provato a sostituire i portafusibili delle lampade, erano già messi un po' male.

Vi aggiorno.

Parallelamente ho verificato che l'IC7 della Interface Board o il relativo segnale di abilitazione non vanno. Tutte le luci pilotate da quell'IC sono spente o lampeggiano in modo erroneo. Devo misurare con l'oscilloscopio per vedere se gli input dell'IC7 sono giusti, in tal caso lo devo sostituire.

Modificato da: edo421 il 18-giu-2020 10.40
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 19-giu-2020 22.08   in risposta a: maxbesoz in risposta a: maxbesoz
 
Per quanto riguarda il reset sporadico credo di aver risolto sostituendo il condensatore della POWER FAILURE C7 con un 35 uF.
Al posto che stabilizzarsi su 4.7v circa dello zener, c'era una sega da 5 a 0.8V
Quando c'erano dei grossi carichi sull'alimentazione scendeva ancor più sotto e andava in reset.

Ho alcuni problemi ancora, ma apro un nuovo thread.
tyutyu007

Messaggi: 107
Registrato: 09-08-08
Re: Restauro Star God e problemi CPU
Postato: 19-giu-2020 22.19   in risposta a: edo421 in risposta a: edo421
 
Maxbesoz ha scritto da qualche parte che con un resistore questo dovrebbe essere impostato su un segnale ALTO costante.
Potrebbe esserci un'interruzione di corrente o uno scarso contatto.
edo421

Messaggi: 48
Registrato: 27-05-20
Re: Restauro Star God e problemi CPU
Postato: 19-giu-2020 22.35   in risposta a: tyutyu007 in risposta a: tyutyu007
 
Si lo so, ma pensandoci meglio non sono d'accordo. Quel segnale arriva da un raddrizzatore dell'alimentatore, non dalla schedina addizionale.
Non è quindi un'uscita open collector (l'altra, che va nel CN9 si, ma ha il pull-up). Se gli metti il pull-up, non fa più nulla, perché l'unico caso in cui si può attivare è quando manca la 5V a quel punto.

Non so se poi quella sega fosse voluta proprio per far si che la 5101 vada immediatamente allo stato di basso consumo quando manca tensione, ma secondo me era troppo sensibile. Se dovesse dare qualche problema, lo scriverò qui. Altrimenti lo consiglio a chi abbia problemi di RESET sporadico.


VecchiFlipper forum © 2010