La Riparazione del Flipper » Argomenti generali » Il forum di Vecchi Flipper


 
Discussione: Hot wheels problema display e accensione

 
Benvenuto, Ospite
Impostazioni Ospite
Questo problema è risolto.


Permlink Risposte: 52 - Pagine: 2 [ 1 2 | Successiva ] - Ultimo Messaggio: 19-gen-2021 20.21 di djparpol91 Discussioni: [ Precedente | Successiva ]
djparpol91

Messaggi: 40
Registrato: 02-03-20
Hot wheels problema display e accensione
Postato: 31-dic-2020 1.57
 
Buonasera a tutti sono sempre alle prese con quel flipper hot wheels da aprile 2020 ci ho messo mesi e anche tante ore di tempo ma sono riuscito a zoccolare tutte le schede del flipper anche quelle display e audio... mi sono atrezzato ho comprato un prova ic e anche il programmatore delle 2708 una volta testato tutte le ic le ho montate sugli zoccoli delle schede finito di montarle mi accorgo c?è un corto su una 2708 quindi la cambio la programmo tramite programmatore il problema sul segnale bus D4 sparisce ma spariscono anche i numeri sui display che in un primo momento spegnendo e accendendo con una 2708 in corto apparIvano numeri causali... ora ho tolto il corto ma sembra tutto morto le tensione di alimentazione ci sono la batteria nuova cosa può essere ?

Allego foto... tutte le ic oppure integrati contrassegnati da puntino rosso sono stati testati o sostituiti con pezzi nuovi ringrazio in anticipo
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 31-dic-2020 7.58   in risposta a: djparpol91 in risposta a: djparpol91
 
Non ci credo hai zoccolato tutto?,
Cpu, la driver, audio e display? 😳😳
da on crederci!! secondo il mio parere da neofita hai fatto un casino bestiale.

Aspetta Fruscio1984 lui con le parole e la tecnica saprà aiutarti in bocca al lupo.

ps:

Ma chi ti ha consigliato ti procedere cosi?

maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 31-dic-2020 8.16   in risposta a: djparpol91 in risposta a: djparpol91
Valido aiuto
ciao,

purtroppo hai fatto un lavoro enorme che però risulta potenzialmente letale per i circuiti stampati, vecchi di 40 anni

I problemi vanno affrontati con metodo, mai sostituire cose senza prima aver ben chiaro il motivo dell'intervento

Da progettista elettronico devo dire che vedo troppe volte interventi insensati, come cambiare cose qua e là sperando di azzeccare il componente guasto.

I circuiti sono sempre divisibili in blocchi funzionali, che vanno analizzati uno alla volta, a seconda del problema che si ha

Il fatto che avessi display accesi, anche con un segnale del data bus in corto, è dovuto al fatto che la Zaccaria, sia sui flipper di prima che di seconda generazione, utilizza, per il rinfresco dei display e delle periferiche, un circuito assimilabile ad un DMA (Direct Memory Access).

E' una soluzione raffinata, molto al di là dei circuiti "brutali" degli americani

In poche parole, esiste una porzione di circuito che fa accesso continuo alla 2101 (IC21 sui prima generazione) e distribuisce i valori letti alle periferiche, senza intervento diretto della cpu 2650 (IC12)

Se il segnale RUN è corretto i display si accendono con numeri tra 0 e 9, anche se il software è piantato

PS: hi verificato le checksum delle eprom riprogrammate, per verificare che sia tutto corretto?

In rete ci sono i files binari da programmare nelle eprom

Controlla il segnale RUN ed il reset

ciao

massimo
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 31-dic-2020 10.09   in risposta a: djparpol91 in risposta a: djparpol91
 
scusate ma io dico, uno che si incimenta su schede elettroniche facendo un lavoro bestiale senza una minima conoscenza non della teoria(perche' almeno quella non fa danni "docet fruscio1984") ma praticando medodi pazzeschi, altro che tempo perso e danni irreversibili.

e in risposta massbersol gli fa la cantilena del professore, spiegando i run i dma, bus, oscilloscopio, misurazioni di colui che, se le sa, non fa quello che ha fatto l'utente!!

quindi in conclusione: chi non ha una minima dimestichezza con i circuiti lasci stare!! meglio farselo riparare (il flipper) da qualcuno che ha saldato qualche filo!! e che cazzarola direbbe ilsogno! tra l'altro risparmieresti anche.

una piccola differenza ma non troppo , riguardo gli elettromeccanici, perche' anche facendo danni

sono sempre recuperabili in quando non hanno schede elettroniche..ecco perche' il maestro fruscio1984 parla parla ma i fili non li connette mai... ma non importa perche' a furia di collegare a casaccio qualcosa combina.

saluti e buona vigilia.....

e buon 2021
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 31-dic-2020 13.05   in risposta a: maxbesoz in risposta a: maxbesoz
Valido aiuto
ciao,

proprio perché l'amico ha fatto un lavoro enorme, anche se sbagliato, sono convinto che ci tenga a sapere di più sulle schede che possiede.

Io cerco di dare informazioni tecniche, se uno non capisce può sempre chiedermi spiegazioni

Per me è fondamentale che le persone affrontino i lavori con competenza, se manca e posso aiutare, perché no?

Del resto, dopo anni di frequentazione del sito, ho aiutato tantissimi a venire a capo dei problemi e spero che almeno qualcuno abbia approfondito la propria conoscenza elettronica

Ciò che più mi spaventa è la mancanza di competenza, ormai di moda nel nostro paese

Imparare è difficile senza dubbio, ma è l'unico modo per crescere

Certamente un flipper elettronico è più complesso di un elettromeccanico, ma è anche enormemente più affidabile ed economico, altrimenti perché i costruttori del tempo avrebbero fatto tanti sforzi per passare all'elettronica?

Provate a riparare, senza le giuste conoscenze, una Advance Unit elettromeccanica o ad allineare perfettamente la marea di lamelle dei relè, poi se ne riparla

Tra l'altro, volendo, l'elettronica digitale presente nei flipper non richiede neanche grandi conoscenze specifiche, certo non è semplice, ma affrontabile

Vediamo se riusciremo a venire a capo dei problemi di questo povero Zaccaria

Auguri di Buon anno a tutti gli amici del sito

massimo
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 31-dic-2020 15.06   in risposta a: maxbesoz in risposta a: maxbesoz
 
inzitutto ho zoccolato tutto per praticita,quando i pezzi in futuro si romperanno o avranno problemi... troppo facile mettere una scheda nuova che con 300 euro piu display led il gioco sarebbe finito... lo faccio per passione hobby ed esperienza personale , ho un'oscilloscopio ,stazione saldante weller ,dissaldatore weller ecct le schede erano messe male perche qualcuno prima di me aveva pocciato per sistemarle ,ora le ho ripristinate non guardando la spesa solo perche se no sarebbe finito il gioco ma anche sopratutto il passatempo esperiena e cultura lo voglio aggiustare io arragiandomi chiedendo qualche consiglio cercare di capire di piu la tecnologia di quei anni e ringrazio la pazienza
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 1-gen-2021 23.25   in risposta a: maxbesoz in risposta a: maxbesoz
 
scusa massimo per controllare il segnale reset e run c'è una scheda ben chiara di come eseguire il tutto senza fare danni passo-passo ?

di dove mettere la sonda, la massa, il tester, con disegno dell'oscilloscopio di quello che deve vedersi a ogni misura

grazie in anticipo marco
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 4-gen-2021 23.11   in risposta a: djparpol91 in risposta a: djparpol91
 
Ho il segnale di clock tp9
Ho il segnale Run alto
Ho il segnale alto tp16
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 4-gen-2021 23.31   in risposta a: djparpol91 in risposta a: djparpol91
 
Ciao, cacchio hai tutta questa attrezzatura a livello di Nasa :-)) e vieni in un forum a chiedere aiuto dopo aver sostituito na marea di integrati zoccolati? scusa se sono cosi incuriosito.
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 5-gen-2021 8.38   in risposta a: djparpol91 in risposta a: djparpol91
Valido aiuto
ciao,

sull'oscilloscopio vedo un'onda quadra, ma non vedo le impostazioni orizzontali (time/div)

Vedo però 20.0V come divisione verticale. L'onda quadra dovrebbe essere alta 1/4 di quadretto (5V), in foto mi sembra ben di più, per cui la domanda è spontanea: hai collegato la massa dell'oscilloscopio alla massa della scheda?

Dato che il filo di massa della sonda normalmente è molto corto, per non cambiare continuamente posizione al coccodrillo di massa, ti consiglio di usare un filo di prolunga con due coccodrilli, un lato lo fissi alla massa della scheda (per esempio sui fori di fissaggio scheda che sono metallizzati) e l'altro al coccodrillo della sonda

Il clock, sui prima generazione, deve essere intorno agli 890KHz, molto approssimativi, dato il generatore RC a monostabile (IC19)

Su TP16 hai il segnale di INTREQ (Interrupt Request). Qui la frequenza deve essere tra i 7.2ms e gli 8.2ms (anche qui molto indicativa)

Su TP18 hai il segnale RUN negato (nRUN d'ora in poi). Deve essere bassso. Sul pin 10 di IC39 devi avere il segnale RUN alto.

TP18 è su Q negato di (IC39/9), mentre IC39/10 è Q, quindi devono sempre essere uno opposto all'altro

Comunque, se su TP16 hai un segnale alto fisso, ciò è dovuto al run errato. Non avendo segnale di Interrupt, ovviamente non funzionerà nulla

Il circuito che genera l'interrupt è un flip/flop Set/Reset settato dal temporizzatore costituito da metà di IC39 e resettato dal segnale INTACK (Interrupt Acknowledge) con OPREQ (Operation Request) gestiti dal 2650 (IC12)

Controlla con l'oscilloscopio i vari segnali del 2650 e fai un report esatto

Il segnale nRUN deve essere basso. Il funzionamento è il seguente:

Ad intervalli più o meno regolari, l'uscita del decoder IC11/6 si porta alta e poi bassa. Questo da il trigger al monostabile contenuto nell'altra metà di IC39.

IC39 è un 4528, cioè un monostabile retriggerabile, per cui, se gli impulsi di trigger arrivano sempre prima che scada il periodo del monostabile, impostato da R19 e C16, le sue uscite rimarranno stabili, Q negato a 0 e Q ad 1

Questo costituisce un classico circuito di watch-dog (cane da guardia)

Ovviamente IC11 deve funzionare. E' un decoder con uscite attive alte

Il tutto è gestito dal software e dal reset

Se il software non funziona per problemi vari o il reset TP6 è piantato ad 1, il watch-dog manterrà nRUN alto, bloccando tutto

Purtroppo l'argomento richiede pagine di spiegazione, però controlla tutti i segnali del 2650. Se sono a posto, controlla IC24/11, deve commutare continuamente (abilita, a 0, il decoder IC11)

Poi IC24/4 deve commutare sempre (è l'abilitazione alla scrittura su Ram)

Per ora fermiamoci qui perché mi rendo conto che il tutto è troppo lungo

Comunque il funzionamento della scheda non è troppo complicato, certo non è facile descriverlo in modo semplice

ciao

massimo

Modificato da: maxbesoz il 5-gen-2021 8.39

Modificato da: maxbesoz il 5-gen-2021 8.40
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 5-gen-2021 8.53   in risposta a: maxbesoz in risposta a: maxbesoz
 
maxbesoz ha scritto:
ciao,

sull'oscilloscopio vedo un'onda quadra, ma non vedo le impostazioni orizzontali (time/div)

Vedo però 20.0V come divisione verticale. L'onda quadra dovrebbe essere alta 1/4 di quadretto (5V), in foto mi sembra ben di più, per cui la domanda è spontanea: hai collegato la massa dell'oscilloscopio alla massa della scheda?

Dato che il filo di massa della sonda normalmente è molto corto, per non cambiare continuamente posizione al coccodrillo di massa, ti consiglio di usare un filo di prolunga con due coccodrilli, un lato lo fissi alla massa della scheda (per esempio sui fori di fissaggio scheda che sono metallizzati) e l'altro al coccodrillo della sonda

Il clock, sui prima generazione, deve essere intorno agli 890KHz, molto approssimativi, dato il generatore RC a monostabile (IC19)

Su TP16 hai il segnale di INTREQ (Interrupt Request). Qui la frequenza deve essere tra i 7.2ms e gli 8.2ms (anche qui molto indicativa)

Su TP18 hai il segnale RUN negato (nRUN d'ora in poi). Deve essere bassso. Sul pin 10 di IC39 devi avere il segnale RUN alto.

TP18 è su Q negato di (IC39/9), mentre IC39/10 è Q, quindi devono sempre essere uno opposto all'altro

Comunque, se su TP16 hai un segnale alto fisso, ciò è dovuto al run errato. Non avendo segnale di Interrupt, ovviamente non funzionerà nulla

Il circuito che genera l'interrupt è un flip/flop Set/Reset settato dal temporizzatore costituito da metà di IC39 e resettato dal segnale INTACK (Interrupt Acknowledge) con OPREQ (Operation Request) gestiti dal 2650 (IC12)

Controlla con l'oscilloscopio i vari segnali del 2650 e fai un report esatto

Il segnale nRUN deve essere basso. Il funzionamento è il seguente:

Ad intervalli più o meno regolari, l'uscita del decoder IC11/6 si porta alta e poi bassa. Questo da il trigger al monostabile contenuto nell'altra metà di IC39.

IC39 è un 4528, cioè un monostabile retriggerabile, per cui, se gli impulsi di trigger arrivano sempre prima che scada il periodo del monostabile, impostato da R19 e C16, le sue uscite rimarranno stabili, Q negato a 0 e Q ad 1

Questo costituisce un classico circuito di watch-dog (cane da guardia)

Ovviamente IC11 deve funzionare. E' un decoder con uscite attive alte

Il tutto è gestito dal software e dal reset

Se il software non funziona per problemi vari o il reset TP6 è piantato ad 1, il watch-dog manterrà nRUN alto, bloccando tutto

Purtroppo l'argomento richiede pagine di spiegazione, però controlla tutti i segnali del 2650. Se sono a posto, controlla IC24/11, deve commutare continuamente (abilita, a 0, il decoder IC11)

Poi IC24/4 deve commutare sempre (è l'abilitazione alla scrittura su Ram)

Per ora fermiamoci qui perché mi rendo conto che il tutto è troppo lungo

Comunque il funzionamento della scheda non è troppo complicato, certo non è facile descriverlo in modo semplice

ciao

massimo

Modificato da: maxbesoz il 5-gen-2021 8.39

Modificato da: maxbesoz il 5-gen-2021 8.40


Caspita max..... Menomale ti fermi ! a me è venuto mal di testa! 😂 Complimenti very good😉
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 9-gen-2021 18.14   in risposta a: maxbesoz in risposta a: maxbesoz
 
Questo è quello che succede sulla scheda... cosa devo fare ?
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 9-gen-2021 18.14   in risposta a: maxbesoz in risposta a: maxbesoz
 
Questo è quello che succede sulla scheda... cosa devo fare ?
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 9-gen-2021 19.23   in risposta a: maxbesoz in risposta a: maxbesoz
 
Questo è quello che trovo i in cpu...

Il pin 22 è alto...

Le uscite bus sono tutte uguali circa come onda tranne la dbus 7 più bassa

Dove ho scritto basso il segnale è a 0

Dove ho scritto alto il segnale è alto

Da ADR12 a ADR 8 il segnale è uguale stessa frequenza

Mentre da ADR7 a ADR1 l?onda di restringe ma rimane alta uguale

ADR0 onda stretta ma segnale più dimezzato rispetto ad altri ADR

spero mi capite... grazie

Modificato da: djparpol91 il 9-gen-2021 19.24

pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 9-gen-2021 19.37   in risposta a: djparpol91 in risposta a: djparpol91
 
mamma mia e mo? fai prima a prendere qualche scheda usata se no il fumo ti esce dalla capa
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 9-gen-2021 20.33   in risposta a: pool10 in risposta a: pool10
 
Aiutami invece di dirmi cosa devo fare nella vita 😉
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 9-gen-2021 21.43   in risposta a: djparpol91 in risposta a: djparpol91
 
Non riesco è più facile averla davanti la cpu e ripararla, che farlo qui non ne sono capace troppo complicato.
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 0.40   in risposta a: djparpol91 in risposta a: djparpol91
Soluzione al problema
ciao,

direi che il software non gira affatto

Però hai indicato su di un foglio che leggi su TP3 4.26V e questo non va bene. Sei fuori tolleranza per alimentare i TTL (4.75 - 5.25V)

Sei sicuro della misura, visto che poi sull'altro foglio mi indichi che INTREQ è a 5V?

Se l'alimentazione fosse giusta (TP3=5V circa) allora quello che scrivo dal punto 1 in poi ha senso, altrimenti prima devi capire cosa non va sull'alimentazione a 5V

Su CN7/5 devi leggere circa 5.6V e su TP3 circa 5V+-0.25V

Se su CN7/5 non leggessi 5.6V circa, potrebbe darsi che ci sia una scheda che assorbe troppo e siede lo stabilizzatore della Power. Allora dovresti staccare una ad una le schede e vedere chi siede l'alimentazione

1- Il clock ha il valore che ti avevo indicato (circa 890KHz con molta approssimazione, dato il generatore a monostabile RC)?

Sicuramente la cpu non è in reset, visto che hai indicato 0.166V

INTREQ è alto, visto che il generatore di interrupt è bloccato

INTACK è quindi ovviamente basso

RUN/WAIT è alto ad indicare uno stato interno di run, ma significa nulla

Domanda: sei sicuro del tuo 2650?

Hai la possibilità di leggere le eprom per verificare le checksum?

Altrimenti la vedo dura

Come progettista ti potrei anche suggerire di farti uno schedino che esca con 40 pin come il 2560 da applicare al posto del processore e poter così gestire i segnali staticamente per analizzare tutta la circuiteria al contorno, ma mi ci vorrebbe molto tempo per le spiegazioni ed a te per la costruzione
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 1.19   in risposta a: maxbesoz in risposta a: maxbesoz
 
L?ho alimentato a banco per essere più comodi ma a cn7 ho dato + 5 volt +12 -5 e massa
Non ho dato 5,60

Il clock 845.000

Ho programmato le eprom tutte nuove la prima è una 2716 e verificata

Le altre ho programmate con un programmatore per solo 2708 e verificate

2650a n cpu nuova
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 8.47   in risposta a: djparpol91 in risposta a: djparpol91
 
djparpol91 ha scritto:
L?ho alimentato a banco per essere più comodi ma a cn7 ho dato + 5 volt +12 -5 e massa
Non ho dato 5,60

Il clock 845.000

Ho programmato le eprom tutte nuove la prima è una 2716 e verificata

Le altre ho programmate con un programmatore per solo 2708 e verificate

2650a n cpu nuova


Sono in dubbio sulle eprom, qulle originali non ci stavano?

Hai programmato delle nuove con programmatore autocostruito o acquistato?

Perche', le 2708 sono ostiche

Hai verificato dopo programmate?

CPU - Original
ROM Image File Type Checksum
ROM1 HOTWHEEL.IC1 2716 9A8E
ROM2 HOTWHEEL.IC2 2708 4A8E
ROM3 HOTWHEEL.IC3 2708 48CF
ROM4 HOTWHEEL.IC4 2708 4BCB
ROM5 HOTWHEEL.IC5 2708 577A

maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 9.51   in risposta a: djparpol91 in risposta a: djparpol91
 
ciao,

a banco devi assolutamente dare 5.6V

Ricordati che sulle zaccaria c'è un diodo in seria ai 5V, per questo in ingresso devi dare circa 0.6V in più dei 5V

Se fai funzionare a 4.25V i TTL rischiano di lavorare in zona lineare e non va assolutamente bene dal punto di vista delle dissipazioni interne

Riguardo le checksum di pool10, ricorda che la ROM 3 ha un seriale a bordo, per cui potrebbe non avere la stessa checksum 0x48CF

Questi sono i link al sito di David Gersic dove ci sono tutti i files delle eprom zaccaria di prima e seconda generazione: http://www.zaccaria-pinball.com/gen1/games.html

http://www.zaccaria-pinball.com/gen2/games.html

Il clock di 845KHz è accettabile

Una volta certi che le eprom siano ok, passerei all'analisi dei segnali di decodifica

Certo uno schedino da mettere al posto del 2650 aiuterebbe moltissimo perchè permetterebbe almeno l'analisi dei segnali in situazione statica e controllabile

ciao

massimo

Modificato da: maxbesoz il 10-gen-2021 9.51
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 9.56   in risposta a: maxbesoz in risposta a: maxbesoz
 
Nel primo linck leva la virgola se no, non va🙂

Ok ok😅

Modificato da: pool10 il 10-gen-2021 9.57
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 11.17   in risposta a: maxbesoz in risposta a: maxbesoz
 
Qui ho costruito i led per le uscite di cn 10 che mi rimangono accesi fissi uscita pin 3 e 4

Se mi dici cosa devo costruire lo costruisco....

Sotto il programmatore artigianale costruito da un amico.

Ricontrollerò le eprom
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 12.32   in risposta a: djparpol91 in risposta a: djparpol91
 
ciao,

per dirti cosa costruire devo prima farne lo schema elettrico

Sappi che ti ci vorranno un 74HCT245, 2 o 3 74HCT244 e 5 zoccoli DIL 20 pin per questi integrati

Poi due strip maschio, meglio se a pin arrotondati, tassativi nel caso sulla tua scheda sia montato uno zoccolo da 40 pin torniti

Poi 4 dip-switch da 8 poli e qualche strip resistiva (o resistenze singole)

Però devi pazientare, perché devo concludere una trentina di schede da inviare al mio socio in belgio e poi devo finire due progetti, sia firmware che hardware

Quindi potrò lavorare alla schedina molto a spizzichi

Ultima cosa: al posto degli HCT puoi usare anche gli HC, i costi sono praticamente uguali, molto meno di 1? cadauno

Gli HC hanno range di alimentazione da 2 a 6V, mentre gli HCT hanno range di alimentazione TTL (4.75 - 5.25V) e gli ingressi hanno valori 0 ed 1 CMOS (HC) o TTL (HCT)

buona domenica

massimo

Modificato da: maxbesoz il 10-gen-2021 12.32

Modificato da: maxbesoz il 10-gen-2021 14.46
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 16.40   in risposta a: maxbesoz in risposta a: maxbesoz
 
molti dei materiali elencarti li ho gia attendo tuo progettino grazie
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 16.48   in risposta a: djparpol91 in risposta a: djparpol91
 
Sempre più intetessante sto 3d
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 19.27   in risposta a: maxbesoz in risposta a: maxbesoz
 
.

Modificato da: djparpol91 il 10-gen-2021 20.11
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 19.33   in risposta a: djparpol91 in risposta a: djparpol91
 
.

Modificato da: djparpol91 il 10-gen-2021 20.12
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 19.35   in risposta a: maxbesoz in risposta a: maxbesoz
 
.

Modificato da: djparpol91 il 10-gen-2021 20.12
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 21.34   in risposta a: djparpol91 in risposta a: djparpol91
 
djparpol91 ha scritto:
.

Modificato da: djparpol91 il 10-gen-2021 20.12

Non mi dire che si comincia a vedere qualche puntoni ai display?

djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 22.34   in risposta a: pool10 in risposta a: pool10
 
tp14 rimane alto e non si abbassa ic39 cambiato cambiato ic41 3081 ma niente da fare fermo con le 4 frecce ora cè qualcuno ha le foto TP che si devono vedere sull'oscilloscopio ?

perchè solo il clock ho capito che vabene il resto non capisco che onde devo vedere grazie
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 23.06   in risposta a: djparpol91 in risposta a: djparpol91
 
djparpol91 ha scritto:
tp14 rimane alto e non si abbassa ic39 cambiato cambiato ic41 3081 ma niente da fare fermo con le 4 frecce ora cè qualcuno ha le foto TP che si devono vedere sull'oscilloscopio ?

perchè solo il clock ho capito che vabene il resto non capisco che onde devo vedere grazie


Ma scusa non avevi sostituito tutto l'arsenale?

Mo che fai risostituisci tutti! 😂 😂 😂 😂 😂
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 10-gen-2021 23.18   in risposta a: pool10 in risposta a: pool10
 
Si la 220 era scorrazzata un po? ovunque e ho cambiato tutto... a parte memorie statiche che le sto aspettando 5101 e 2101 tenendo conto che ho comprato questo flipper rotto mai funzionato in mano a me.
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 11-gen-2021 0.05   in risposta a: djparpol91 in risposta a: djparpol91
 
Azzz la 220!
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 11-gen-2021 9.06   in risposta a: djparpol91 in risposta a: djparpol91
 
ciao,

ecco proprio le ram possono fare la differenza tra la vita e la morte della scheda cpu

Abbi pazienza, mi ci vorrà un po' di tempo per lo schema, sono troppo occupato

Magari risolvi prima, ma lo pubblicherò ugualmente

ciao

massimo
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 11-gen-2021 10.57   in risposta a: djparpol91 in risposta a: djparpol91
 
un mio conoscente ha tanta di quella roba schede 1 e 2 e driver

non si sa mai ...
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 11-gen-2021 13.29   in risposta a: maxbesoz in risposta a: maxbesoz
 
Sto costruendo un piccolo tester sram 5101 dato ho 2 flipper con le stesse schede è tutta esperienza l?ho trovato qui su vecchi flipper...
Attendo il tuo progetto ho già mandato a prendere i pezzi che mi mancavano per farlo

Buona a sapersi che la 5101 e le 2101 fanno la differenza della scheda spero sono quelle.

Grazie ancora
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 11-gen-2021 13.30   in risposta a: pool10 in risposta a: pool10
 
Buona a sapersi se serve qualcosa ti dirò grazie
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 11-gen-2021 23.33   in risposta a: maxbesoz in risposta a: maxbesoz
 
Max mentre facevo i test di leon mi sono accorto che sotto la
Cpu c?erano un paio di piste messe male così ho notato che anche il dil della eprom 5 è messo male...
Così stavo pensato di cambiare i dill gli unici che non ho cambiato eprom e cpu e ho notato sono molto ossidati tenendente all?azzurro...
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 19.08   in risposta a: djparpol91 in risposta a: djparpol91
 
le batterie fanno sempre danni...altro che cambiare 1000000 zoccoli :-) )
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 19.14   in risposta a: djparpol91 in risposta a: djparpol91
 
per corettezza ,come hanno fatto altri chiudi questa e apri in zaccaria!

non vedo perche' tu debba continuare qui


il moderatore puo' solo pubblicare guide !! :-)

quindi caro djparpol91 fai no sforzo sposta in zaccaria

ps:

ma il tuo nick e' del famoso gruppo hard rock? ;-)

maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 21.31   in risposta a: djparpol91 in risposta a: djparpol91
 
ciao,

mamma mia com'è messa male la scheda!!

Sto ultimando lo schema, però per le spiegazioni di come operare non so se basteranno due pagine

Quindi metto le mani avanti.

Una volta fatta la scheda, dovrai armarti di pazienza e, dallo schema elettrico della cpu zaccaria capire come utilizzare lo schedino per i test in statica. Ovviamente scriverò due dritte quando ne avrò il tempo

Credo che rilascerò due versioni, una senza ed una con il refresh del watch-dog.

Il perché è presto detto: per utilizzare il refresh si deve dissaldare il pin 12 di U39 e collegarlo con filo e pinzetta alla scheda di test. Quindi si deve manomettere la scheda cpu

Anticipo che non ho usato il 74HCT245, ma solo i 74HCT244

ciao

massimo
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 21.34   in risposta a: maxbesoz in risposta a: maxbesoz
 
se hai un'idea di qualche prodotto che faccia miracoli per sistemarla un pò meglio dopo aver sistemato le piste lo accetto volentieri,

grazie massimo per l'impegno a presto

Modificato da: djparpol91 il 12-gen-2021 21.35
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 21.47   in risposta a: djparpol91 in risposta a: djparpol91
 
Hai molta foga di fare ma secondo me se avessi chiesto prima.. non avresti fatto tanto lavoro inutile

Ste cose pasticciate io le ho fatte all'età di 15/16 anni con succhiastagno a Mano senza lente a 5 diottrine senza oscilloscopio :-) Però ci riuscivo a portare a termine la riparazione..

Ti auguro di riuscirci, ma ripeto sei partito al contrario :-)
djparpol91

Messaggi: 40
Registrato: 02-03-20
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 22.10   in risposta a: pool10 in risposta a: pool10
 
avresti dovuto vedere la scheda come era messa prima...avresti buttato via tutto garantito !!!

io quando faccio le cose,le faccio da 0 e non lascio roba messa male.

poi ognuno ha le sue idee io ho passato 4 mesi a casa, qualcosa da fare l'ho trovato per non annoiarmi giusto o sbagliato.

aggiungo e ripeto non sono un fenomeno dell'elettronica ma sto facendo esperienza.
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 22.18   in risposta a: djparpol91 in risposta a: djparpol91
 
non ho mai buttato nulla fidati...se racconto tutto non basta un forum mi perderei pure io.... ;-) )

non si tratta di essere un fenomeno..il fenomeno qui e' maxbez....
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 23.01   in risposta a: djparpol91 in risposta a: djparpol91
 
ciao,

come promesso ecco il primo schema di simulatore statico 2650 senza refresh watch-dog

Oggi mi sono sorbito due black-out, uno di 4 ore ed un di mezz'ora, ulteriori ritardi sul lavoro!!

Chiaramente sono possibili molte aggiunte / modifiche per rendere il tutto più performante, ma è un buon punto di partenza

ATTENZIONE, dimenticavo di dire che i due schedini vanno bene per i prima generazione, i seconda generazione hanno resistenze di pull-up da 10K sui bus dati, indirizzi e sui segnali di controllo

Proprio questi ultimi darebbero problemi, visto che sullo schedino c'è una rete resistiva da 2K2. L'1 logico sarebbe perfetto, ma lo 0 logico sarebbe di circa 0.9V, fuori specifica. Meglio montare una rete da 1K, in modo di avere lo 0 logico a circa 0.45V

Chiaramente il tutto è fatto nell'ottica di usare meno integrati possibile e risparmiare filature sullo schedino

ciao

massimo

Modificato da: maxbesoz il 13-gen-2021 15.23
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 12-gen-2021 23.43   in risposta a: djparpol91 in risposta a: djparpol91
 
ciao,

ed ecco lo schema con il generatore di refresh watch-dog

Il periodo del clock T=90us è molto approssimativo, dipendendo dalla dispersione del coefficiente K del 74HCt132 e dalle tolleranze di R1, C5

Chiaramente sono possibili molte aggiunte / modifiche per rendere il tutto più performante, ma è un buon punto di partenza

Ho fatto tutto molto in fretta, chiedo scusa per eventuali errori o spiegazioni non chiare

massimo

Modificato da: maxbesoz il 13-gen-2021 8.04
pool10

Messaggi: 270
Registrato: 12-10-20
Re: Hot wheels problema display e accensione
Postato: 13-gen-2021 9.49   in risposta a: maxbesoz in risposta a: maxbesoz
 
ORA SCARICO per curiosita', ma in verita' per mia ignoranza mai usati questi addons

ciao
maxbesoz


Messaggi: 1.007
Registrato: 31-08-07
Re: Hot wheels problema display e accensione
Postato: 13-gen-2021 15.42   in risposta a: pool10 in risposta a: pool10
 
ciao a tutti,

allego gli schemi dello schedino con e senza il refresh del watch dog con l'interfaccia del 2650 adatta anche per i seconda generazione. L'unica differenza rispetto ai precedenti è che SW4 è collegato a massa e la rete resistiva RSIP3 a 5V

Non l'ho detto in precedenza, ma è ovvio che il VCC e la massa disegnati sullo schema vengono presi dallo zoccolo del 2650, pin 39 e 21 rispettivamente

Il refresh del watch dog è un segnale che non ha nulla a che fare con il 2650 ed è utilizzabile solo sulle schede cpu di prima generazione

ciao

massimo

Modificato da: maxbesoz il 13-gen-2021 15.43


VecchiFlipper forum © 2010